Getting File Explorer to open at root of D:

User avatar
PaulB
BronzeLounger
Posts: 1509
Joined: 26 Jan 2010, 20:28
Location: Ottawa ON

Getting File Explorer to open at root of D:

Post by PaulB »

Windows 8/8.1:

I'm trying to change the task bar shortcut to File Explorer to open at the root of D: (that is not a smiley!) by setting the target in the shortcut properties to "%windir%\explorer.exe /n,/e, D:".

I can modify the target in all the shortcuts on the task bar except for the File Explorer one. Its target field (and others) is grayed out. Nor can I change the target field by accessing the File Explorer shortcut at:

C:\Users\XXX\AppData\Roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar

Can anyone point me in the right direction?

Thanks.
Regards,
Paul



User avatar
Rudi
gamma jay
Posts: 25314
Joined: 17 Mar 2010, 17:33
Location: Cape Town

Re: Getting File Explorer to open at root of D:

Post by Rudi »

Does it help if you hold down SHIFT when you right click on the file explorer icon (on the taskbar)? Is the target property "ungreyed"?

Also BTW: You may need to add a backslash after your line: "%windir%\explorer.exe /n,/e, D:"
Like this: "%windir%\explorer.exe /n,/e, D:\"
Regards,
Rudi

If your absence does not affect them, your presence didn't matter.

User avatar
PaulB
BronzeLounger
Posts: 1509
Joined: 26 Jan 2010, 20:28
Location: Ottawa ON

Re: Getting File Explorer to open at root of D:

Post by PaulB »

Gave your suggestion a try, Rudi, but it had no effect. Thanks.
Regards,
Paul



User avatar
HansV
Administrator
Posts: 71983
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Getting File Explorer to open at root of D:

Post by HansV »

It works perfectly in Windows 7. Has Windows 8 really changed so much?
Regards,
Hans

User avatar
PaulB
BronzeLounger
Posts: 1509
Joined: 26 Jan 2010, 20:28
Location: Ottawa ON

Re: Getting File Explorer to open at root of D:

Post by PaulB »

HansV wrote:It works perfectly in Windows 7. Has Windows 8 really changed so much?
Apparently so. I've used this tip for many versions of Windows without any problems until I installed Win 8 last year. At that time, MS replaced Windows Explorer with File Explorer. Its default task bar shortcut seems to be treated as a special case protected shortcut. I eventually got it to work as I wanted but when I upgraded to Win 8.1, the problem returned. The thing is, I can't remember what I did last year to resolve the issue. Will keep looking!
Regards,
Paul



User avatar
Jay Freedman
Microsoft MVP
Posts: 1148
Joined: 24 May 2013, 15:33
Location: Warminster, PA

Re: Getting File Explorer to open at root of D:

Post by Jay Freedman »

There are apparently two kinds of shortcuts (I see this in Win7 also). Program installers can create shortcuts that aren't customizable. The old kind that you can mess with can be created by right-clicking the executable -- in this case, %windir%\explorer.exe -- and clicking Send To > Desktop.

Then you can change the target and any other settings you need. If you want, you can replace the taskbar icon with the one from the desktop, and then delete the one that's cluttering the desktop.

By the way, it seems you can get to the root folder of a drive with or without the backslash, either D: or D:\ will do.

JoeP
SilverLounger
Posts: 1651
Joined: 25 Jan 2010, 02:12

Re: Getting File Explorer to open at root of D:

Post by JoeP »

Try this. Pin a File Explorer. Open File Explorer. Drag the drive you want to the taskbar to pin it. It will appear in the "pinned" section for the already pinned File Explorer.

If you do it this way you can have multiple folders pinned.

Joe
Joe

User avatar
Rudi
gamma jay
Posts: 25314
Joined: 17 Mar 2010, 17:33
Location: Cape Town

Re: Getting File Explorer to open at root of D:

Post by Rudi »

Jay Freedman wrote:There are apparently two kinds of shortcuts (I see this in Win7 also). Program installers can create shortcuts that aren't customizable. The old kind that you can mess with can be created by right-clicking the executable -- in this case, %windir%\explorer.exe -- and clicking Send To > Desktop.

Then you can change the target and any other settings you need. If you want, you can replace the taskbar icon with the one from the desktop, and then delete the one that's cluttering the desktop.

By the way, it seems you can get to the root folder of a drive with or without the backslash, either D: or D:\ will do.
Ha...hows that! I did this exact process...it worked..so I was coming here to document it and I read your post Jay. So I can confirm, it works!
SP2-Fri,25-10.jpg
You do not have the required permissions to view the files attached to this post.
Regards,
Rudi

If your absence does not affect them, your presence didn't matter.

User avatar
PaulB
BronzeLounger
Posts: 1509
Joined: 26 Jan 2010, 20:28
Location: Ottawa ON

Re: Getting File Explorer to open at root of D:

Post by PaulB »

Thanks for all the advice, gentlemen. I will be experimenting with your suggestions and reporting back.
Regards,
Paul



User avatar
PaulB
BronzeLounger
Posts: 1509
Joined: 26 Jan 2010, 20:28
Location: Ottawa ON

Re: Getting File Explorer to open at root of D:

Post by PaulB »

Well, I experimented with various solutions this week and cannot come up with a solution that precisely solves the original issue. The work-around that Joe suggested perhaps works best and has the added benefit, as he points out, of allowing for multiple folders to be pinned.

Jay's suggestion appears, at first blush, to work exactly as required. I created a File Explorer shortcut on the desktop and customized it to open the root of "D:". I then unpinned the File Explorer shortcut originally on the taskbar and pinned the new shortcut to the taskbar and deleted the copy from the desktop.

When I clicked on the new FE shortcut, File Explorer opened as I wanted at the root of D. But I noticed that a second occurrence of the FE shortcut appeared on the taskbar (see Rudi's screen shot, above). It disappeared when I closed FE, but always came back when I clicked on the shortcut. The new one that pops up is the very original unmodifiable shortcut that I unpinned. I can tell because the jump lists for both shortcuts are different.

Microsoft must treat that shortcut as very special.
Regards,
Paul