FastStone Image Viewer problem.

User avatar
weese237
2StarLounger
Posts: 189
Joined: 26 Jan 2010, 23:39
Location: Florida, USA

FastStone Image Viewer problem.

Post by weese237 »

HI,

Is anyone having a problem with the Clone and Heal in the FastStone Image Viewer software? This is what it is currently doing for me:

I click on the Clone and Heal icon or hit the O keyboard shortcut. The Clone and Heal windows comes up but a quarter of the window is off the screen to the right. I can't move it back at all. The top of the window doesn't work either. I have to click on the top left icon of the window and choose "restore" and then the window comes back to the middle of the screen. Then I have to click on the "maximize" square at the top right so I can work on my photos. I have to do this every time I want to edit a photo.

I have the current version of the software. I have written to support three times since August and they have never responded. This only started a few months ago and now I'm wondering if I should go back to an earlier version. Maybe it's a setting, but I can't find one.

Thanks,
Louise     :smile:

User avatar
HansV
Administrator
Posts: 78388
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: FastStone Image Viewer problem.

Post by HansV »

I have the latest version too, but Clone and Heal works as intended. I don't see anything in Settings that would affect Clone and Heal...

Have you tried completely uninstalling the application, then reinstalling it?
Best wishes,
Hans

User avatar
weese237
2StarLounger
Posts: 189
Joined: 26 Jan 2010, 23:39
Location: Florida, USA

Re: FastStone Image Viewer problem.

Post by weese237 »

Yes. Did that the other day. I even downloaded a new file in case mine was corrupt for some reason. No difference. I also went back a version. I don't know why they aren't responding to my inquiries.
Louise     :smile:

User avatar
HansV
Administrator
Posts: 78388
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: FastStone Image Viewer problem.

Post by HansV »

That's a pity. Andrew Lu was always quick to answer my queries... :sad:
Best wishes,
Hans

User avatar
weese237
2StarLounger
Posts: 189
Joined: 26 Jan 2010, 23:39
Location: Florida, USA

Re: FastStone Image Viewer problem.

Post by weese237 »

That's nice. I even gave them a couple of donations. Oh well. I'll try an even earlier version.
Louise     :smile:

User avatar
HansV
Administrator
Posts: 78388
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: FastStone Image Viewer problem.

Post by HansV »

You might try deleting all files in the folders

C:\Users\<username>\AppData\Local\FastStone\FSIV

and

C:\Users\<username>\AppData\Roaming\FastStone\FSIV

where <username> is your Windows login name.
If you bought a license key for FastStone Image viewer, you will have to enter it again.
Best wishes,
Hans

User avatar
weese237
2StarLounger
Posts: 189
Joined: 26 Jan 2010, 23:39
Location: Florida, USA

Re: FastStone Image Viewer problem.

Post by weese237 »

Hi Hans,
I deleted the files in the C:\Users\<username>\AppData\Local\FastStone\FSIV folder. No change except if I leave the setting for "Associated image launches in" to Full Screen, it still puts the window off the screen but I can move it back. However, it doesn't have a maximize button so I really can't use it. If I put it back to what I prefer which is Windowed View, everything is the same.

I do not have a C:\Users\<username>\AppData\Roaming\FastStone\FSIV folder at all. Am I supposed to?

Thanks for trying. I guess I'll just use another software if I need to do some cloning.
Louise     :smile:

User avatar
HansV
Administrator
Posts: 78388
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: FastStone Image Viewer problem.

Post by HansV »

That may be a remnant of an older version, the files in that folder on my PC are quite old. So don't worry about that.

I'm sorry I wasn't able to solve your problem! :sad:
Best wishes,
Hans

User avatar
weese237
2StarLounger
Posts: 189
Joined: 26 Jan 2010, 23:39
Location: Florida, USA

Re: FastStone Image Viewer problem.

Post by weese237 »

That's ok. Thanks for trying. Hopefully they will respond.
Louise     :smile:

User avatar
weese237
2StarLounger
Posts: 189
Joined: 26 Jan 2010, 23:39
Location: Florida, USA

Re: FastStone Image Viewer problem.

Post by weese237 »

I went back and installed version 7.5. Same problem. At this point I'm wondering if it has to do with Windows 11. Something to do with the size of the windows maybe. I certainly don't know. LOL
Louise     :smile:

User avatar
HansV
Administrator
Posts: 78388
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: FastStone Image Viewer problem.

Post by HansV »

I have Windows 11 too...
Best wishes,
Hans

chikara
NewLounger
Posts: 7
Joined: 13 Feb 2024, 15:07

Re: FastStone Image Viewer problem.

Post by chikara »

I have the same problem with the Clone and Heal tool in FastStone Image Viewer. It is very annoying and frustrating. I think it is a bug in the latest version of the software, because I did not have this issue before. I also contacted the support, but they did not reply to me either. I hope they fix it soon. One possible solution that I found is to quit and restart the app, as suggested by Wikipedia. This sometimes solves the problem, but not always. Another option is to use an external editor for cloning and healing, such as ACDSee Editor 2008, which has a better implementation of this tool, according to Glen Barrington. I like FastStone Image Viewer for its simplicity and speed, but this bug is making me consider switching to another software. I wish they would update the editor and improve the clone/heal function. It seems that there is not much difference between the clone and heal modes, as Ray UK pointed out.

User avatar
HansV
Administrator
Posts: 78388
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: FastStone Image Viewer problem.

Post by HansV »

I don't think it's a problem with the software per se - as mentioned above, it works OK for me. I have the latest version n Windows 11.
Best wishes,
Hans

User avatar
weese237
2StarLounger
Posts: 189
Joined: 26 Jan 2010, 23:39
Location: Florida, USA

Re: FastStone Image Viewer problem.

Post by weese237 »

Hello Chikara,
Still having the same problem. Restarting it doesn't work for me. I truly wish they would reply to the requests for help. I've written to them three times on this issue with no response.
I'm beginning to believe it is not the software however. It also happened while I was using FastStone Photo Resizer. I can't duplicate it so I don't know how that happened. :smile: I think it may be a Windows issue at this point. I either deleted some files I shouldn't have or installed some software it didn't like or when I changed the size of my windows display properties and then changed it back or maybe something else. This has been happening to me since August of last year so I certainly can't remember what I was doing at that time to have caused this. I really don't know how to troubleshoot that either. I should look into finding out if my laptop has everything it supposed to have to run smoothly.
Thanks for letting me know I'm not alone.
Louise     :smile:

User avatar
weese237
2StarLounger
Posts: 189
Joined: 26 Jan 2010, 23:39
Location: Florida, USA

Re: FastStone Image Viewer problem.

Post by weese237 »

Thought I'd give an update.
I decided to reformat and reinstall Windows 11 on my laptop. There were other things that were happening so I decided to get the bugs out and do a fresh install. Did it like "a new computer". I reinstalled FastStone Image Viewer early before a lot of other software that I use and unfortunately nothing changed. Still doesn't work right for cloning and healing. FastStone never replied to any of my help requests. Very disappointing.
So installing on a "new" system didn't do anything. There's something in my setup it doesn't like.
Louise     :smile:

User avatar
HansV
Administrator
Posts: 78388
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: FastStone Image Viewer problem.

Post by HansV »

That's too bad! :sad:
Best wishes,
Hans