Amazon.com not displaying correctly on all of my browsers

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

I am using IE 10. Amazon appears to be consistently displaying correctly over the last week. I cannot identify a pattern to the behavior.
Regards,

JMT

User avatar
BobH
UraniumLounger
Posts: 8709
Joined: 13 Feb 2010, 01:27
Location: Temple - Deep in the Heart of Texas

Re: Amazon.com not displaying correctly on all of my browser

Post by BobH »

Have we established what sort of network connections the various computers use? Are some wired and some wifi? The intermittent nature suggests to me that there is at least one hardware issue and possibly more.

Check the network port connection on the problem computer. If it is wifi, is the receiver built-in or is it a USB receiver? If the latter, check the condition of the USB port itself and the fit of the receiver device in the port. Is it possible that some cables might rub against it?

If the network connection is cabled, check the card in the computer to see if it is properly seated and firmly connected. Is the RJ45 connector properly attached to the cable? Is the RJ45 port on the NIC card sound? If the problem persists, try switching out the network card with one known to work correctly. Check the cable ends at the computer and at the router or switch. Without specialized equipment, it is nearly impossible to check a cable for continuity; so you might try substituting a cable known to be 'good' and see if the problem goes away.

There is also the possibility that you have an issue with the mobo or other parts internal to the computer. Heat is the enemy of all things electronic. Most manufacturers, IMO, skimp on fans and cooling to save production costs. Users sometimes modify systems in ways that affect heat build up.

You mention that you notice the problem most frequently when loading Amazon pages which are usually very rich in content and quite complex. You also mention problems with other web pages, IIRC. That suggests to me that it is hardware - including connectivity - that causes the problem because none of the software suggestions worked (though I doubt they can be ruled out).

WARNING: WAR STORY
Many years ago, in the dim dark days of proprietary networks built on facilities run by communications companies, I had a client that had frequent but intermittent problems communicating with our mainframe. No amount of diagnostics from our center could detect a problem other than a break in communications signalling. The communications provider techs never found a problem when working trouble tickets we opened. After months of this, we did an analysis of the time of day that each failure occurred. Part of the network facilities used shortwave towers instead of physical cabling. After much brouhaha with the carrier, they put 24x7 surveillance on each leg of the circuit. Eventually we found that sunlight and darkness caused enough temperature differential on the dish antenna to break up signalling. The problem resolved itself over an hour or so as surface temperatures on the equipment evened out.


HTH
Bob's yer Uncle!
(1/2)(1+√5)
Intel Core i5, 3570K, 3.40 GHz, 16 GB RAM, ECS Z77 H2-A3 Mobo, Windows 10 >HPE 64-bit, MS Office 2016

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

I am connected to the Internet via Wifi. Whether at home or at work, when connected via Wifi, I experience these issues. Another computer at home is also connected via Wifi, but it does not have these issues. I do not believe I said that I am having this issue on any other web sites or that I have them only on content-rich Amazon web sites. I experience the problem intermittently (about 1 in every 3 visits on Amazon) and when they occur, they occur on all Amazon pages.

Just now, Amazon.com was displaying problematically. Based on your post, I plugged in my computer to my router via an Ethernet cable. The problems displaying immediately ceased. Perhaps the issue is with my Wifi Internet router, but then why would I only have issues displaying Amazon.com?
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75203
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

The most likely explanation is that Amazon.com in general is more demanding than the other websites that you visit, and that the 'problem' computer is experiencing slower wifi speed than your other computers. As a result of this combination, Amazon pages sometimes fail to load fully on the 'problem' computer.
Regards,
Hans

User avatar
BobH
UraniumLounger
Posts: 8709
Joined: 13 Feb 2010, 01:27
Location: Temple - Deep in the Heart of Texas

Re: Amazon.com not displaying correctly on all of my browser

Post by BobH »

I agree with Hans!

Sorry about misunderstanding your post. Using the Ethernet cable removed the problem; so there must be a wifi signalling problem or an incompatibility between the wifi connection and the demands Amazon makes.

You mention that the problem travels to work with you on the same computer; therefore I think your wifi router is exonerated. The problem then is likely the wifi receiver in your computer. Is it a USB receiver or is it built into the computer? If the former, try a different USB dongle. If it has a built-in wifi receiver, I have no idea how to determine whether or not it is working correctly. If it resides in a card, you might try switching out the card. Did you examine all cable connections inside the PC case to ensure there are none loose or any which might be affecting internal connectivity?

That about runs out my string of diagnostics. What is the make and model of your computer? We might be able to do some web surfing to find out if there are others experiencing the same thing and what - if anything - they've done to fix it.

Good luck!
Bob's yer Uncle!
(1/2)(1+√5)
Intel Core i5, 3570K, 3.40 GHz, 16 GB RAM, ECS Z77 H2-A3 Mobo, Windows 10 >HPE 64-bit, MS Office 2016

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

My Wifi receiver is built in to my computer.
This is a laptop – HP Pavilion g4. I am afraid if I open it up and start fiddling with wires I will cause some permanent damage.
Regards,

JMT

User avatar
BobH
UraniumLounger
Posts: 8709
Joined: 13 Feb 2010, 01:27
Location: Temple - Deep in the Heart of Texas

Re: Amazon.com not displaying correctly on all of my browser

Post by BobH »

jmt356 wrote:My Wifi receiver is built in to my computer.
This is a laptop – HP Pavilion g4. I am afraid if I open it up and start fiddling with wires I will cause some permanent damage.
Perhaps you can find a technician who can open it and check or replace the wifi receiver. Before you do, you might want to go to some of the PC hardware forums and see if your particular model of the hp laptop is giving similar problems to others. I'm all out of suggestions with these.
Bob's yer Uncle!
(1/2)(1+√5)
Intel Core i5, 3570K, 3.40 GHz, 16 GB RAM, ECS Z77 H2-A3 Mobo, Windows 10 >HPE 64-bit, MS Office 2016

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

After several weeks of being able to access Amazon.com, the issue started recurring again a few weeks ago. Each time I visit any Amazon.com web page, Internet Explorer states "

I suspect there might be some kind of malware involved (see http://forums.cnet.com/7723-6122_102-29 ... mazon-com/" onclick="window.open(this.href);return false;, which states a similar problem and concludes with "Malware took over my host file and both amazon and paypal were in that file. At first I couldn't save the file, but then found out that my anti-virus software was locking out any changes. I shut down the anti-virus long enough to edit the host file and now I'm back in business").

So I just turned off my Internet and ran Avast, which found 53 files with the error "Archive is password protected. (42056)"

These files are all located in the folder AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\0THOFADV\. The files have varying names, including:
mplayer_freely.exe|>config.xml
mplayer_freely.exe|>darkux_dynamic_compliant.vi.zip
etc.

However, I tried searching for that folder, both with invisible folders turned off and then on, and could not find it. The furthest I reach is AppData\Local\Microsoft\Windows\, and I cannot get to Temporary Internet Files.

So my questions are:
- First, are these 53 files malware?
- Second, how can I reach them to delete or modify them if the folder that appears in Avast does not appear in Internet Explorer?
- How can I quarantine or delete these files if they are password protected and I do not have the password?

On a slightly related topic, I found so many folders with bizarre names while I was navigating to AppData\Local\Microsoft\Windows\, including:
CLR_v2.0
CLR_v2.0_32
IME12
IMJP8_1
IMJP9_0
1024
1033
Sqm
WER
WinX

As well as various random files I did not recognize, including:
appsFolder.itemdata-ms
appsFolder.itemdata-ms.bak
WindowsUpdate.log

I wonder if all of this might also be malware.
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75203
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

Try running the free version of Malwarebytes Anti-Malware.
Regards,
Hans

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

A 25 Nov. 2014 Malwarebytes scan with Internet on resulted in “No malicious items were detected."

Perhaps I need to try again with Internet turned off.
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75203
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

Malwarebytes is pretty thorough even with internet turned on.
Check the browser add-ins, and the Programs and Features control panel. Do you see anything unusual there?
Regards,
Hans

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

I had the same result with Malwarebyes when I tried scanning with the Internet turned on. It seems that the files in the
AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\0THOFADV\ folder are able to evade detection by making themselves invisible; I cannot even find this folder when I search for it manually.

When I search for Temporary Internet Files in my C drive, I do find two folders by that name, but they are for different user names. The Temporary Internet Files that Avast is identifying is for my user name, but I cannot find that folder when I search for it manually.

The thing I find unusual about Programs and Features is that only a small portion of the programs I installed are displayed. This was the topic of a previous thread that I started and is the reason why I now uninstall my programs through CCleaner.

I am not sure how to check which add-ins I have installed in IE, but I do not believe the problem is with the add-ins because I have the same issue displaying Amazon.com in Firefox and Google Chrome.
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75203
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

In order to see Temporary Internet Files and its subfolders, you must (1) Show hidden files, folders and drives, and (2) NOT hide protected operating system files. See screenshot of the Organize > Folder and search options dialog, View tab (from Windows Explorer):
S015.png
You do not have the required permissions to view the files attached to this post.
Regards,
Hans

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

Thank you for that. I was finally able to find the Temporary Internet Files folder and to navigate on down to Content.IE5\0THOFADV\. When I open that last folder, it seemed that many of the items were harmless. Many of them were jpgs of web sites I had visited, including banners and other images, and items I had downloaded, including pdfs.

However, I did not see the files that Avast was saying could not be scanned because the "Archive is password protected." These files include:
mplayer_freely.exe|>config.xml
mplayer_freely.exe|>darkux_dynamic_compliant.vi.zip
etc.

The only file I found with a similar name was:
mplayer_freely.exe

Is this the same as all those other files, whose names start with "mplayer_freely.exe" but then are followed by a vertical bar ("|") and other characters?

mplayer_freely.exe is a suspicious program according to Google (http://www.google.com/search?q=mplayer_ ... ss&ie=&oe=" onclick="window.open(this.href);return false;). Can I just delete it?
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75203
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

I'd definitely remove it, if possible. You may be able to remove it by clearing your IE browser cache.
Regards,
Hans

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

I launched CCleaner and deleted Temporary Internet Files, History, Cookies, Index.dat files, etc.
This removed everything in the 0THOFADV folder except for avatarCA2AVQV8.jpg and QjK2hWv6uak[1].htm.
Then, when I visited Eileenslounge, favicon[1].ico (of the Eileenslounge witch that appears next to the address bar) popped up on the 0THOFADV folder.
I then scanned Content.IE5 and its subfolder 0THOFADV and was able to do so with no threat found.

I then visited Amazon.com, but it still did not load.

I am going to try to run some updates.
Regards,

JMT

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

I just downloaded and installed 83 updates, but Amazon.com is still not loading. I continue to get the error message that Amazon "This page cannot be displayed."

I then tried connecting to the Router Via an Ethernet Cable, and I was immediately able to view the contents of Amazon.com without incident.

Perhaps the problem is with my router, but I suspect there is something wrong with how my computer is trying to access Amazon.com. When I enter http://www.Amazon.com" onclick="window.open(this.href);return false; into my browser, I come to the Google search results page http://www.google.com/search?q=www.amaz ... ss&ie=&oe=" onclick="window.open(this.href);return false;.

I then click on the second link on that page, which is supposed to take me to http://www.google.com/url?q=http://www. ... Ei4aUfKnNw" onclick="window.open(this.href);return false;.

However, when I click on that link, Internet Explorer states "This page can't be displayed
"Make sure the web address http://www.google.com" onclick="window.open(this.href);return false; is correct."

I suspect that there is either something wrong with my router or that something in my computer that is misdirecting Internet Explorer to the wrong page whenever I type in Amazon.com as the domain address.

Does the fact that I am able to view Amazon.com when connected through a VPN or through another computer using TeamViewer or Citrix rule out the possibility that the problem is with my wireless router?
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75203
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

It does seem likely that there is a problem with your wireless connection.
Regards,
Hans

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

HansV wrote:It does seem likely that there is a problem with your wireless connection.
But why then am I able to view Amazon.com if I connect via another computer using TeamViewer through my wireless connection?

Wouldn't that indicate that the issue is more likely something on my computer that is misdirecting IE and my other Internet browsers?
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75203
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

I give up, sorry. I have no idea.
Regards,
Hans