Amazon.com not displaying correctly on all of my browsers

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Amazon.com not displaying correctly on all of my browsers

Post by jmt356 »

I am having trouble viewing all of the Amazon.com pages on IE, Chrome and FireFox. I thought perhaps Amazon.com was down, but when I try on a different computer, it is fine. On my computer, however, the pages take a long time to load, many images do not download and the frames are all out of place, with hyperlinks and other content displayed in list format rather than in a "table" format.

This issue is intermittent. Two weeks ago, I had issues. Then last week, the content displayed correctly. Today, the content is all out of place again.

What could be causing this?
Regards,

JMT

User avatar
Rudi
gamma jay
Posts: 25430
Joined: 17 Mar 2010, 17:33
Location: Cape Town

Re: Amazon.com not displaying correctly on all of my browser

Post by Rudi »

Try doing a cleanup on your temp files, and internet cache.
Run an app like CCleaner and see if that makes a difference.
Regards,
Rudi

If your absence does not affect them, your presence didn't matter.

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

In Internet Explorer, I deleted Temporary Internet files and web site files, Cookies and website data and History in Tools | Options | Delete Browsing History, but the problem persists.
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75204
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

Can you post a screenshot? Perhaps that will provide a clue...
Regards,
Hans

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

Please see attached. It looks normal from other computers, even on this same network.
You do not have the required permissions to view the files attached to this post.
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75204
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

Thanks. It looks like the page failed to load completely - the CSS (cascading style sheets) haven't been applied, and most of the pictures aren't displayed. This is usually caused by a timeout, and the most likely explanations for that are either that the site is slow or that your internet connection is slow or intermittent.
Since the problem occurs on your computer only, my guess is that there is a problem with your internet connection. It takes so long to download the Amazon page that the browser gives up.
Regards,
Hans

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

My Internet connection is fast, with roughly 20 mb/s download speed and 1 mb/s upload speed. If speed were the issue, the problem would occur on all computers on my network. However, another computer that I have on this network does not experience these problems; it loads and displays Amazon.com correctly. Also, I would have similar issues with other web pages viewed on this computer. However, Amazon.com is displayed correctly on other computers on this network and all other web pages, with the exception of Amazon.com, load and display correctly on this computer.

With that being said, I believe there is some issue with the page taking too long to load. It takes a long time for IE to load Amazon.com and then, when it finally does load, it appears without the CSS, etc. However, what I am unable to understand is why Amazon.com specifically is taking so long to load, and on this computer only.

BTW, clearing my cookies and temporary internet files and then restarting my computer does not help.
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75204
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

Very mysterious. I'm afraid I don't have an explanation or solution.
Regards,
Hans

User avatar
stuck
Panoramic Lounger
Posts: 7250
Joined: 25 Jan 2010, 09:09
Location: retirement

Re: Amazon.com not displaying correctly on all of my browser

Post by stuck »

I echo Rudi's suggestion - run Ccleaner to ensure your IE cache really is cleared. In my experience problems like this where the CSS is not applied are always fixed by ensuring your browser is getting a fresh copy of the page(s) from the site.

Ken

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

I ran CCleaner v3.22. It may have made a slight difference in that the problem with Amazon may be occurring slightly less frequently, but it still occurs. I cannot identify a pattern as to when it happens. Can the issue be that CCleaner v3.22 is too old?
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75204
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

Although v3.22 is over 20 months old (the current version is v4.13), I don't think it would make a huge difference.
It won't hurt to download and install the current version though - it's free, after all. See Update: CCleaner v4.13 released.
Regards,
Hans

User avatar
stuck
Panoramic Lounger
Posts: 7250
Joined: 25 Jan 2010, 09:09
Location: retirement

Re: Amazon.com not displaying correctly on all of my browser

Post by stuck »

jmt356 wrote:...the problem with Amazon may be occurring slightly less frequently, but it still occurs...
What version of Internet Explorer are you using?

If less than IE9 then that might be the problem as IE8 and lower are all beyond end-of-life. Amazon is unlikely to spend time making their site compatible with the rendering quirks of an obsolete browser.

Ken

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

I am using IE 10, but the issue is not just limited to IE; I experience the same problem on Chrome and Mozilla Firefox.

I will try to download the updated version of CCleaner.
Regards,

JMT

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

Downloading, installing and running the most recent version of CCleaner did not help, nor did downloading and installing the latest updates to Mozilla Firefox and then viewing Amazon.com on Firefox. In both cases, Amazon still runs very slowly and displays incorrectly.

I am now downloading and installing 60 updates for MS Office, MS Windows, etc. Hopefully that will make some difference.
Last edited by jmt356 on 30 Apr 2014, 20:43, edited 1 time in total.
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75204
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

Have the date and time been set correctly on the problem computer? (Just grasping at straws, really)
Regards,
Hans

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

The date and time are correct on my computer.

I installed around 70 backlogged updates that Avast has been telling me about (but that I have been ignoring because I generally avoid updates since they usually interfere with my settings) and today, Amazon displayed correctly. However, I am not sure if this is a one-off or if the issue has been definitively resolved, since in the past, the issue has come and gone. If the problem recurs, I will post back.
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75204
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

Were those updates for your antivirus program? Or does Avast remind you of Windows and/or other updates?
You should always keep your antivirus program up-to-date.
Regards,
Hans

jmt356
SilverLounger
Posts: 2228
Joined: 28 Mar 2010, 01:49

Re: Amazon.com not displaying correctly on all of my browser

Post by jmt356 »

I believe Avast was reminding me of Windows and other updates.

Today, Amazon is again not displaying properly, so whatever success I had on 1 May was not permanent. Restarting the computer did not help.
Last edited by jmt356 on 03 May 2014, 18:09, edited 1 time in total.
Regards,

JMT

User avatar
HansV
Administrator
Posts: 75204
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Amazon.com not displaying correctly on all of my browser

Post by HansV »

I'm afraid I still don't have a clue. I don't think we'll be able to solve this.
Regards,
Hans

User avatar
stuck
Panoramic Lounger
Posts: 7250
Joined: 25 Jan 2010, 09:09
Location: retirement

Re: Amazon.com not displaying correctly on all of my browser

Post by stuck »

Every time I've seen this sort of behaviour I've fixed it by clearing the cache / forcing the browser to reload a fresh copy of the problem page. As to why the CSS gets corrupted in the cache I've no idea but when it's happened to me at work and our intranet doesn't render properly it's because the network is having a bad day. By extension this suggests the problem lies with your connection to Amazon.

Why only Amazon and not other pages? Perhaps the way Amazon serves the pages, i.e. the order in which the various elements that make up their page(s) are sent down the wires is more prone to corruption over a weak spot in your network. If your problem PC is on a wired connection try swapping the Ethernet cable on it for a brand new one. If it's wireless check the line of sight from it to the router / access point.

Also, I asked previously but you didn't answer, what version of Internet Explorer are you using? If version 8 or less then that is another possible source of the problem as they are obsolete browsers and Amazon are not going to be spending time writing web pages that are compatible with ancient software.

Ken