Dymo LabelWriter printing blank labels

User avatar
BobArch2
5StarLounger
Posts: 1119
Joined: 25 Jan 2010, 22:25
Location: Pickering, Ontario, Canada

Dymo LabelWriter printing blank labels

Post by BobArch2 »

If your Dymo LabelWriter is printing blank labels it is because of a recent Windows update. Dymo Tech Support have resolved the issue by creating updated software.

Their web site says:

DYMO Software compatibility issues with Microsoft Windows Update.

The latest Windows update has caused some issues with printing blank labels from our software. Our team has been able to fix the issue in DYMO Connect, DYMO Label Software and DYMO ID (XTL) by introducing a new update. In order to run the latest software update in DYMO Connect, please open it, click “Help”, “Check for Updates” and download the latest version. Alternatively, you can download the newest version of our software DYMO Connect here.. In order to download the latest DYMO Label software update click here, and for DYMO ID software update click here.


Albeit their note above says "Click here" I have not included the hot links. I would suggest using their first suggestion of opening the software, click Help and Check for updates.

Hope this helps...
Regards,
Bob

User avatar
BobH
UraniumLounger
Posts: 8141
Joined: 13 Feb 2010, 01:27
Location: Temple - Deep in the Heart of Texas

Re: Dymo LabelWriter printing blank labels

Post by BobH »

Thanks, Bob. I need to do that! :cheers:
Bob's yer Uncle!
Story of my life: I knew better but did it anyway!
Intel Core i5, 3570K, 3.40 GHz, 16 GB RAM, ECS Z77 H2-A3 Mobo, Windows 7 >HPE 64-bit, MS Office 2016