Aaaaargh! .NET again

User avatar
silverback
5StarLounger
Posts: 690
Joined: 29 Jan 2010, 13:30

Aaaaargh! .NET again

Post by silverback »

After updating with Microsoft's 'critical' updates yesterday, my PC boot up time has virtually doubled. I've found that a service -
Microsoft .NET Framework NGEN v4.0.30319_X86 - is sitting there with the service showing "STARTING". It does eventually start which allows the rest of the bootup items to start, but while it's in this 'starting' state, I can't do anything because it's preventing the networking stuff from starting.

Can I stop this service? I have no idea what it does apart from slowing things down.

Thanks
Silverback

User avatar
HansV
Administrator
Posts: 72594
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Aaaaargh! .NET again

Post by HansV »

I'd try uninstalling .NET Framework 4; I don't think you'll need it on Windows XP.
Regards,
Hans

User avatar
silverback
5StarLounger
Posts: 690
Joined: 29 Jan 2010, 13:30

Re: Aaaaargh! .NET again

Post by silverback »

HansV wrote:I'd try uninstalling .NET Framework 4; I don't think you'll need it on Windows XP.
You could be right - I've just had a look at the service and it's now stopped. I'll try uninstalling.
Are there any precautions I should take before uninstalling?

Thanks
Silverback

User avatar
HansV
Administrator
Posts: 72594
Joined: 16 Jan 2010, 00:14
Status: Microsoft MVP
Location: Wageningen, The Netherlands

Re: Aaaaargh! .NET again

Post by HansV »

I'd set a restore point before doing so.
Regards,
Hans